Matvey0061
05.08.2022 16:49

дана температура в градусах цельсия. Напишите программу для вычисления соответствующей температуры в градусах Фаренгейта. Формура перевода: tF=9/5*tC+35​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bogdanlesja1
10.03.2021 15:48

На Питоне.

У вас в задании формула пересчёта из Цельсия в Фаренгейты неправильная.

c = float(input('Введите температуру в градусах Цельсия: '))

print(f'Эквивалентно {round(9*c/5+32,2)} градусам по Фаренгейту')

Или с проверкой формата входных данных:

while True:

 try:

  c = float(input('Введите температуру в градусах Цельсия: '))

  print(f'Эквивалентно {round(9*c/5+32,2)} градусам по Фаренгейту')

  break

except ValueError:

  print('Неверный формат входных данных')

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота