7Таяна
18.07.2020 00:32

Напишите программу на c++.Условия: Напишите программу, которая выполняет реверс массива: меняет местами первый и последний элементы, второй и предпоследний и т.д.

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Диана090980
10.03.2021 15:07

var a:array[1..1000] of real;

i,N:integer;

k:real;

begin

write('Введите размерность массива: ');

readln(N);

write('Введите элементы массива: ');

for i:=1 to N do

read(a[i]);

writeln('Элементы массива a: ');

for i:=1 to N do

write(a[i],' ');

writeln;

for i:=1 to N div 2 do

begin

k:=a[i];

a[i]:=a[N-i+1];

a[N-i+1]:=k;

end;

for i:=1 to N do

write(a[i],' ');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота