Даринёк
16.11.2020 21:40

Здравствуйте решить задачу на Питоне, если сможете. Составить программу, которая для двумерного вещественного массива S*T выводит на экран элементы , значения которых находятся вне диапазона от -V до V (V задается) , а произведение их индексов делится без остатка на другое задаваемое число B

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Polinaaa14
13.08.2022 03:28
1) и 2):

a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89]

b = [1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13]

c = []

for i in range(len(a)):

   for j in range(len(b)):

       if a[i] == b[j]:

           c.append(a[i])

print(list(set(sorted(c  # сортировка по возрастанию

print(list(set(sorted(c, reverse=True  # сортировка по убыванию

3):

a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89]

for elem in a:

   if elem < 5:

       print(elem,end = ' ')

4)

a = []

for i in range(102):

   if i == 100:

       a.append(1)

   elif i == 101:

       a.append(1)

   else:

       a.append(0)

print(a)

5)

a = []  

for i in range(90):

   if i % 2 == 0:

       a.append(i)

print(a)

print(len(a))

0,0(0 оценок)
Ответ:
keril936
05.10.2022 13:35
PascalABC.NETbegin ArrRandom(ReadInteger('k:'),-99,99).Println.Slice(1,2).Average.Print end.

Объяснение:

ArrRandom(n,a,b) -- Возвращает массив размера n, заполненный случайными целыми значениями в диапазоне [a,b].Println -- Выводит последовательность на экран, используя пробел качестве разделителя, и переходит на новую строку.Slice(from,step) -- Возвращает срез последовательности от номера from с шагом step.Average -- Возвращает среднее значение последовательности.Print -- Выводит последовательность на экран, используя пробел качестве разделителя.

Пример работы:

37+55 = 9292 / 2 = 46
Найти среднее арифметическое элементов массива С[k], стоящих на четных местах. (Pascal), Закомментир
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота