hanum27082005
11.09.2022 07:12

ОЧЕНЬ НУЖНА Напишите программы в паскале

1.Дана последовательность чисел 20,23,26,29,31,34…n. Составить программу нахождения количества чисел и произведение, оканчивающихся на 3 и сумму остальных чисел.

2.Найти сумму и количество двузначных чисел не кратных 4 и произведение кратных 4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vikatyn
22.04.2021 20:54
Program Diagonal;
uses Crt;
const n = 5;
Type Mas = array [1..n, 1..n] of integer;
       Vec = array [1..n*n] of integer;
var A: Mas;
     V: Vec;
     i, j , k: integer;
     p : longint;
begin
 ClrScr;
 Randomize;
 p:=1;
 WriteLn('Massiv A:');
 for i:=1 to n do
   begin
      for j:= 1 to n do
         begin
           A[i, j]:= 1+random (9);
           p:=p*A[i,i];
           Write(A[i, j]:4);
         end;
   WriteLn; WriteLn;
   end;
k:=0;
for i:=1 to n do
  for j:=1 to n do
      begin
        if (A[i,j]>p) and (j<i) then
          begin
            k:=k+1;
           V[k]:=A[i, j];
          end;
      end;
  WriteLn('Vector V=');
  for j:=1 to k do
     Write(V[j]:4);

  WriteLn;
  if k=0 then Writeln ('None');
ReadLn;
end.
0,0(0 оценок)
Ответ:
Damira123451
07.11.2022 16:54
Program Trapez;      {название программы}    
 uses Crt;               {подключаемый модуль}

 var a, b, alfa: real;   {переменные: стороны и угол при основании трапеции}
     h, S: real;           {переменные: высота и площадь}

begin                       {начало}
 ClrScr;                    {очистка экрана}
 repeat                     {цикл ввода}
   Write (' alfa (w grad) = ');      {ввод угла}
   ReadLn(alfa);
   Write (' a = ');    ReadLn(a);  {ввод большей стороны}
   Write (' b = ');    ReadLn(b);  {ввод меньшей стороны}
 until (a>b) and (alfa<>90) ;      {контроль за вводом: надо а>b и alfa<>90}
 alfa:=alfa*pi/180;                    {перевод в радианы}
 h:=(a-b)/2*sin(alfa)/cos(alfa);    {вычисление высоты}
 S:=(a+b)*h/2;                          {вычисление площади}
 WriteLn(' S = ', S:6:2);            {вывод результата}
 ReadLn;                                {ожидание нажатия ENTER}
end.                                       {конец}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота