dmitriybatulin
20.06.2022 21:34

очень Напишите программу на языке Паскаль для решения задачи:
1. Запросить от пользователя трехзначное натуральное число.
2. Разбить число на цифры.
3. Найти сумму и произведение цифр числа.
4. Вывести на экран ответ "Больше", если сумма больше произведения,
ответ "Меньше" , если сумма меньше произведения
и "Равно", если сумма равна произведению.
​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
чиполина2
04.02.2021 16:10

var a,c1,c2,c3,p,s:integer;

begin

 p:=1;

 read(a);

 c1:=a mod 10;

 a:= a div 10;

 c2:=a mod 10;

 a:= a div 10;

  c2:=a mod 10;

  p:=c1*c2*c3;

  s:=c1+c2+c3;

  if s>p then writeln('больше') else if   s<p then writeln('меньше') else writeln('равно')

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота