Aleksa4nick
11.05.2022 01:28

Паскаль. задается последовательность натуральных чисел. найти среднее арифметических всех отрицательных чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nikita200111
16.06.2020 06:56

Решение #1

 

var a:array[1..1000] of integer;

s,i,k,N:integer;

begin

s:=0;

k:=0;

read(N);

for i:=1 to N do

read(a[i]);

for i:=1 to N do

if a[i]<0 then begin

s:=s+a[i];

k:=k+1;

end;

writeln(s/k);

end.

 

Решение #2;

 

var a,i,s,k,N:integer;

begin

k:=0;

s:=0;

read(N);

for i:=1 to N do begin

read(a);

if a<0 then begin

k:=k+1;

s:=s+a;

end;

end;

write(s/k);

end.

 

Оба решение дают один результат, но первое сделан массивом, а второе простым перебором чисел.

 Формат входных данных

Задается натуральное число N

Затем задается N целых чисел 

Формат выходных данных

 Целое число - среднее арифметическое всех отрицательных чисел

 Пример

Вход

5

1 -2 3 -4 5

Выход

-3

 Вопросы в ЛС

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота