13032005mahri
26.05.2023 22:13

С++. Сколько дней в месяце Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце. При вводе неверного номера месяца должно быть выведено сообщение об ошибке. Считается, что год невисокосный.

Входные данные
Входная строка содержит единственное целое число – номер месяца (возможно, неправильный).

Выходные данные
Выходная строка должна содержать одно целое число – количество дней в этом месяце или 0, если был введён неверный номер месяца.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Багирая
13.01.2024 15:11
Хорошо, давайте решим эту задачу шаг за шагом:

1. Сначала нам нужно объявить переменные для ввода номера месяца и вывода количества дней. Для этого мы можем использовать тип данных int (целое число). Назовем эти переменные "month" и "days".

2. Затем мы должны попросить пользователя ввести номер месяца с клавиатуры. Для этого мы можем использовать функцию "cin" в языке C++. Сохраните введенное пользователем значение в переменную "month".

3. Далее нам нужно проверить, что введенный номер месяца является допустимым значением. В этой задаче месяц может быть только от 1 до 12. Если введенное значение не соответствует этому диапазону, мы должны вывести сообщение об ошибке и установить значение переменной "days" равным 0.

4. Если введенное значение является допустимым номером месяца, мы можем использовать оператор "switch" для определения количества дней в месяце. Для каждого номера месяца у нас будет свой случай "case", где мы присвоим переменной "days" соответствующее количество дней в этом месяце.

5. После завершения оператора "switch" мы должны вывести значение переменной "days" на экран. Для этого мы можем использовать функцию "cout" в языке C++.

Вот как может выглядеть код на C++, решающий эту задачу:

```cpp
#include
using namespace std;

int main() {
int month, days;

cout << "Введите номер месяца: ";
cin >> month;

switch (month) {
case 1: case 3: case 5: case 7: case 8: case 10: case 12:
days = 31;
break;
case 4: case 6: case 9: case 11:
days = 30;
break;
case 2:
days = 28;
break;
default:
cout << "Ошибка: неверный номер месяца." << endl;
days = 0;
break;
}

cout << "Количество дней в месяце: " << days << endl;

return 0;
}
```

В этом примере программа запрашивает у пользователя номер месяца, а затем в соответствии с введенным номером определяет количество дней в этом месяце. Если номер месяца некорректен, программа выводит сообщение об ошибке и устанавливает значение переменной "days" равным 0.

Надеюсь, это поможет вам понять, как можно решить эту задачу с помощью программирования на C++. Если у вас остались какие-либо вопросы, пожалуйста, дайте мне знать!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота