kamila274
14.08.2021 02:14

с информатикой надо записать программу на паскале
кто понимает
буду очень благодарна

Рассматривается множество целых чисел, принадлежащих числовому отрезку [1529; 9482], которые удовлетворяют следующим условиям:
− запись в двоичной системе закачивается на 01;
− запись в пятеричной системе заканчивается на 3.
Найдите минимальное из таких чисел и их сумму. Гарантируется, что искомая сумма не превосходит 107.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
katyaarxipova
05.03.2021 22:25

var

i,a,j,k,b,s,counter : integer;

begin

s := 0;

counter := 1;

for i := 1529 to 9482 do

begin

j:= i;

k := i;

repeat a:= a*10+(j mod 2);

j:=j div 2;

until j=0;

repeat b:=k*10 + (k mod 5);

k:=k div 5;

until k=0;

if (a mod 100 = 01) and (b mod 10 = 3) then

begin

s := s + i;

if counter = 1 then

begin

counter := counter + 1;

writeln('Минимальное такое число:', i);

end;

end;

end;

writeln('Сумма чисел:',s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота