199535
11.10.2020 05:47

Дано четырехзначное число. Написать программу, которая выводит на экран число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lolowkaujw
05.04.2020 22:50

Объяснение:

Мұғалім оқушыларға 20 таңбадан тұратың мәтінді компьютерде теру тапсырмасын берді. → Мұғалім оқушыларға 20 таңбадан тұратың мәтінді компьютерде теру тапсырмасын берді.

Оқушы мәтінді қуатын 16 таңбадан тұратың алфавитпен терді,ал Болат қуаты 256 таңба болатын алфавитпен терді. → Оқушы мәтінді қуатын 16 таңбадан тұратың алфавитпен терді, ал Болат қуаты 256 таңба болатын алфавитпен терді.

Екі түрлі алфавитпен жазылған ақпарат көлемін анықтаңыз және ерекшелігін түсіндірініз. → Екі түрлі алфавитпен жазылған ақпарат көлемін анықтаңыз және ерекшелігін түсіндірініз.

Ақпарат көлемі → Ақпарат көлемі

0,0(0 оценок)
Ответ:
yanachor25
11.04.2022 06:56
1. Вот так это пишется с функцией

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
function IsPrime(n:integer):boolean;
begin
  if n<4 then Result:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    Result:=not found
    end
end;

begin
  Writeln('k=',ArrRandom(ReadInteger('n='),1,999).Println.
    Where(x->IsPrime(x)).Count)
end.

Тестовое решение:
n= 10
401 828 780 444 694 965 23 341 673 875
k=3

2. А вот так это пишется с процедурой

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
procedure IsPrime(n:integer; var res:boolean);
begin
  if n<4 then res:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    res:=not found
    end
end;

begin
  var a:=ArrRandom(ReadInteger('n='),1,999); a.Println;
  var k:=0;
  var prime:boolean;
  foreach var e in a do begin
    IsPrime(e,prime);
    if Prime then Inc(k)
    end;
  Writeln('k=',k)
end.

Тестовое решение:
n= 12
199 43 71 365 417 904 170 212 694 103 161 689
k=4
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота