Demon211108
11.05.2021 17:51

Уровень B. Напишите программу, которая получает день и номер месяца и определяет дату следующего дня. Считайте, что год невисокосный (365 дней). Пример:
Введите день и месяц: 25 12
Следующий день: 26 декабря
Пример:
Введите день и месяц: 28 2
Следующий день: 1 марта

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
belorus70oxm1t1
05.03.2021 10:19

Var

День,Месяц:byte;

Begin

Write('№ дня = ');ReadLn(День);

Var C:=365-День;

Write('№ месяца = ');ReadLn(Месяц);

Case Месяц of

2:C:=C-31;

3:C:=C-59;

4:C:=C-90;

5:C:=C-120;

6:C:=C-151;

7:C:=C-181;

8:C:=C-212;

9:C:=C-243;

10:C:=C-273;

11:C:=C-304;

12:C:=C-334

End;

if (C mod 100>10)and(C mod 100<20) then Write('До нового года осталось ',C,' дней')

else

Case C mod 10 of

1:Write('До нового года остался ',C,' день');

2..4:Write('До нового года осталось ',C,' дня');

0,5..9:Write('До нового года осталось ',C,' дней')

End

End

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота