алекс858
13.09.2020 19:14

Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры два целых числа и выводит на экран сумму чисел, разность между числами, квадрат разности между числами. Обратите внимание на информативность вывода результата. Выводите на экран не только числовые значения, но и текствые комментарии к ним. ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
singerilt
16.05.2023 18:45

ответ:это метасимволы

Объяснение:

Для каждого понятия языка должна существовать единственная мета-

формула, в левой части которой указывается определяемое понятие, т.е.

метапеременная языка БНФ, а правая часть формулы тем или иным

бом задает все множество значений этой метапеременной, т.е. все допусти-

мые конструкции, которые объединяются в это понятие. Для большей

наглядности все понятия (метапеременные) обычно заключаются в спе-

циальные угловые скобки " < " и " > " (предполагается, что эти скобки не

принадлежат алфавиту определяемого языка, т.е. являются метасимвола-

ми), например (число), <арифметическое выражение) и т.д.

0,0(0 оценок)
Ответ:
Саша5601
05.10.2021 14:22
//PascalABC.NET Версия 3.0 Сборка 1150
var n:integer;
begin
  writeln('Сколько стоит товар?');
  readln(n);
  n:=1000-n;
  writeln('Сдача ',n,' рублей. Нужны купюры:');
  writeln(n div 500, ' по 500 рублей, ', (n-(n div 500)*500)div 100, ' по 100 рублей, ', (n mod 100) div 50, ' по 50 рублей, ', (n-(n div 50)*50) div 10,' по 10 рублей, и ещё ', n mod 10, ' рублей мелочью.');
end.

Результат работы:
Сколько стоит товар?
324
Сдача 676 рублей.
Нужны купюры:
1 по 500 рублей, 1 по 100 рублей, 1 по 50 рублей, 2 по 10 рублей, и ещё 6 рублей мелочью.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота