54876
14.12.2022 09:03

Напишите программу (на питоне), которая ищет среди целых чисел, принадлежащих числовому отрезку [125873; 136762], числа, имеющие ровно 5 различных делителей. Выведите эти делители для каждого найденного числа в порядке возрастания.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Сергей0081
04.03.2021 20:31

for number in range(125873, 136763):

   divisors = []

   for divisor in range(2, number // 2 + 1):

       if number % divisor == 0:

           n = divisor

           divisors.append(divisor)

           for _ in range(3):

               n *= divisor

               divisors.append(n)

           if n == number:

               print(f'число = {number}, делители = 1, {", ".join(str(s) for s in divisors)}')

           break

0,0(0 оценок)
Ответ:
масяня114
04.03.2021 20:31

ищет 40 сек

for j in range(125873, 136763):

   count = []

   for i in range(2, j // 2 +1):

       if j % i == 0:

           count.append(i)

           if len(count) > 3:

               break

   if len(count) == 3:

       print(f'число = {j}, делители = 1, {", ".join(str(s) for s in count)}, {j}')

   count.clear()

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота