grusnikot
16.01.2022 22:50

Напишите программу, которая запрашивает у пользователя 5 чисел. Выводит их на экран через запятую. Находит их сумму, произведение и среднее арифметическое на экран. Оформите ответ.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ВаняШколяр4536
02.02.2021 18:40

Первая задача:

var digs:String;

   sum, sr:Real;

   i:Integer;

begin

 writeln('Введите 5 чисел через пробел');

 readln(digs);

 digs := digs.Replace(' ', '');

 sum := 0;

 for i := 1 to 5 do

   sum := sum + strToInt(digs[i]);

 sr := sum / 5;

 writeln('Сумма: ' + sum);

 writeln('Сред. арифметическое: ' + sr);

end.

Ввод:

1 2 3 4 5

Вывод:

Сумма: 15

Сред. арифметическое: 3

Вторая задача:

var i:Integer;

begin

 for i := 0 to 10 do

   writeln(i + '^3=' + i**3);

end.

Вывод:

0^3=0

1^3=1

2^3=8

3^3=27

4^3=64

5^3=125

6^3=216

7^3=343

8^3=512

9^3=729

10^3=1000


Напишите программу, которая запрашивает у пользователя 5 чисел. Выводит их на экран через запятую. Н
Напишите программу, которая запрашивает у пользователя 5 чисел. Выводит их на экран через запятую. Н
0,0(0 оценок)
Ответ:
плаг
22.01.2024 20:11
Хорошо, давайте решим эту задачу шаг за шагом.

Шаг 1: Ввод чисел

Сначала нам нужно запросить у пользователя 5 чисел. Можно сделать это с помощью функции input(), которая позволяет получать ввод от пользователя. Создадим переменные num1, num2, num3, num4, num5 и используем функцию input() для получения ввода от пользователя. Код будет выглядеть так:

```python
num1 = input("Введите первое число: ")
num2 = input("Введите второе число: ")
num3 = input("Введите третье число: ")
num4 = input("Введите четвертое число: ")
num5 = input("Введите пятое число: ")
```

Шаг 2: Преобразование в числа

Функция input() возвращает введенные пользователем значения в виде строк. Чтобы провести математические операции, нам нужно преобразовать эти значения в числа. Для этого мы можем использовать функцию int() или float() (в зависимости от того, являются ли числа целыми или десятичными). Давайте преобразуем наши переменные в числа:

```python
num1 = int(num1)
num2 = int(num2)
num3 = int(num3)
num4 = int(num4)
num5 = int(num5)
```

Шаг 3: Вывод на экран

Теперь, когда у нас есть пять чисел, давайте выведем их на экран. Мы можем использовать функцию print() для этой цели:

```python
print(num1, num2, num3, num4, num5)
```

Шаг 4: Вычисление суммы

Чтобы найти сумму этих чисел, мы можем просто сложить их вместе. Создадим переменную sum и присвоим ей сумму num1, num2, num3, num4 и num5:

```python
sum = num1 + num2 + num3 + num4 + num5
```

Шаг 5: Вычисление произведения

Для нахождения произведения мы умножим все числа вместе. Создадим переменную product и присвоим ей произведение num1, num2, num3, num4 и num5:

```python
product = num1 * num2 * num3 * num4 * num5
```

Шаг 6: Вычисление среднего арифметического

Среднее арифметическое можно найти, разделив сумму чисел на их количество (в данном случае на 5). Создадим переменную average и вычислим среднее арифметическое:

```python
average = sum / 5
```

Шаг 7: Вывод результата

Наконец, выведем на экран результаты. Мы можем использовать функцию print() для вывода значений переменных sum, product и average:

```python
print("Сумма:", sum)
print("Произведение:", product)
print("Среднее арифметическое:", average)
```

Вот и все! Весь код:

```python
num1 = input("Введите первое число: ")
num2 = input("Введите второе число: ")
num3 = input("Введите третье число: ")
num4 = input("Введите четвертое число: ")
num5 = input("Введите пятое число: ")

num1 = int(num1)
num2 = int(num2)
num3 = int(num3)
num4 = int(num4)
num5 = int(num5)

print(num1, num2, num3, num4, num5)

sum = num1 + num2 + num3 + num4 + num5
product = num1 * num2 * num3 * num4 * num5
average = sum / 5

print("Сумма:", sum)
print("Произведение:", product)
print("Среднее арифметическое:", average)
```

Теперь программа будет запрашивать 5 чисел, выводить их на экран и вычислять сумму, произведение и среднее арифметическое.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота