ivanovasasha2
22.08.2020 17:54

Составьте программу, которая запрашивает цифру от 1 до 10 и рисует эту цифру в графическом окне

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
высшийразум68
20.08.2021 03:21

=== Python 3.8.3 ===

import statistics

import re

def TakeFromFile(fname, SingleDataPackCapacity):

   with open(fname, 'r', encoding='utf-8') as input_:

       data = input_.read()

       data = re.sub(r' +', ' ', re.sub(r'\n', ' ', data)).split(' ')

   LastTakeIndex = 0

   for TakeIndex in range(SingleDataPackCapacity, len(data)+SingleDataPackCapacity, SingleDataPackCapacity):

       yield data[LastTakeIndex:TakeIndex]

       LastTakeIndex = TakeIndex

for number, WeekData in enumerate(TakeFromFile('input.txt', 7)):

   tmp = list(map(int, WeekData))

   print(

       f'Week: {number+1}\nMax temp: {max(tmp)}\nMin temp: {min(tmp)}\nAverage temp: {statistics.mean(tmp)}\n')

0,0(0 оценок)
Ответ:
polyakkate
16.11.2022 06:14

Параметрическое моделирование (параметризация) — моделирование (проектирование) с использованием параметров элементов модели и соотношений между этими параметрами. Параметризация позволяет за короткое время «проиграть» (с изменения параметров или геометрических соотношений) различные конструктивные схемы и избежать принципиальных ошибок.

Объяснение:

Параметрическое моделирование существенно отличается от обычного двумерного черчения или трёхмерного моделирования. Конструктор в случае параметрического проектирования создаёт математическую модель объектов с параметрами, при изменении которых происходят изменения конфигурации детали, взаимные перемещения деталей в сборке и т. п.

Идеи параметрического моделирования появились ещё на ранних этапах развития САПР, но какое-то время не могли быть осуществлены по причине недостаточной компьютерной производительности

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота