барынмай
27.08.2022 14:50

Дано целое трёхзначные число. Составьте программу, в результате выполнения которой первая и последняя цифра поменяются местами. Значение числа x введите с клавиатуры, результат выведите на экран

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DAVIDUIOP
27.06.2021 23:29

#include <iostream>

using namespace std;

int main()

{

   int a, b, c;

   int amount = 0;

   cin >> a >> b >> c;

   if (a > 0)

   {

       amount += a;

   }

   if (b > 0)

   {

       amount += b;

   }

   if (c > 0)

   {

       amount += c;

   }

   cout << amount;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main()

{

   int a, b, c;  // Создание целочисленных переменных a, b, c

   int amount = 0;  // Создание целочисленной переменной amount, которая будет хранить сумму положительных чисел. Значение переменной = 0

   cin >> a >> b >> c;  // Ввод с клавиатуры значений переменных a, b, c

   if (a > 0)  // Если значение переменной a > 0

   {

       amount += a;  // К значению переменной amount прибавляем значение переменной a

   }

   if (b > 0)  // Если значение переменной b > 0

   {

       amount += b;  // К значению переменной amount прибавляем значение переменной b

   }

   if (c > 0)  // Если значение переменной b > 0

   {

       amount += c;  // К значению переменной amount прибавляем значение переменной c

   }

   cout << amount;  // Вывод значения переменной amount

}

0,0(0 оценок)
Ответ:
Jeembo23
03.07.2022 19:23

Зависит от содержания сайта и аспектов заданного вопроса...

-Если сайт чист и не имеет графического оформления - то он может работать лишь на результате вывода математических величин из ЦПУ, сохраняя данные в буфере (ОЗУ).

- Если имеются любые графические файлы на сайте, особенно "тяжелые" (допустим, видео формата mp4) то графический ускоритель необходим для обработки такого формата.

PS

Также если говорить про нынешнею ситуацию - то ГПУ сейчас в браузерах работает в качестве аппаратного ускорителя.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота