MainkraeTV
29.12.2022 17:54

Язык Pascal. Напишите программу, которая позволяет вводить координаты двух точек на плоскости. (координаты целочисленые) и выводит на экран расстояние между ними.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
BELENKAYAEN
03.03.2021 21:28

program  z1;

var xa,ya,xb,yb:integer;

begin

write('Введите координаты первой точки: ');

read(xa,ya);

writeln('Введите координаты второй точки: ');

read(xb,yb);

writeln('Расстояние между точками равно: ',sqrt(sqr(xb-xa)+sqr(yb-ya)):0:3);

end.

Объяснение:

Расстояние между двумя точками A(xa, ya) и B(xb, yb) на плоскости:

AB = \sqrt{(xb - xa)^{2} + (yb - ya)^{2}}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота