прости17
10.09.2020 11:03

Написать программу, которая определяет максимум, минимум и среднее трех чисел. Числа ввести с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ксю878
03.03.2021 20:02

program a1;

Var

a,b,c,max,min:integer;

Begin

Readln(a,b,c);

if (a = b) or (a = c) or (b = c) or ((a = b) and (b = c)) then

writeln('Ошибка, числа должны быть разными');

if (a>b) and (a>c) then max:=a;

if (b>a) and (b>c) then max:=b;

if (c>a) and (c>b) then max:=c;

if (a<b) and (a<c) then min:=a;

if (b<a) and (b<c) then min:=b;

if (c<a) and (c<b) then min:=c;

Writeln('Max:', max, ' Min:', min);

write('Среднее арифметическое:',(a+b+c)/3);

end.


Написать программу, которая определяет максимум, минимум и среднее трех чисел. Числа ввести с клавиа
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота