Машунчик225
29.03.2021 03:26

Уважаемые пользователи с проблемой. В языке программирования C# есть триггер Collider.OnTriggerEnter, и нам хотелось бы узнать как вписать в этот триггер transform.position, что бы при входе объекта в колайдер он телепортировался на определенную точку. (Если можно, то хотелось еще с примером)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Кусик11
10.08.2020 01:11

1) Var i:Integer;

A:array[1..10]of integer;

Begin

Write('Введите пять цифр') ;

For i:=1 to 5 do begin

Read(a[i]) ;end;

Write('Кратные двум') ;

For i:=1 to 5 do begin

If a[i] mod 2 =0 then write(' ', a[i]) ;

End;

Write('кратные четырем') ;

For i:=1 to 5 do begin

If a[i] mod 4 =0 then write(' ', a[i]) ;

End;

End.

2)Var a, b, k, i:integer ;

Begin

Write(' a=') ;read(a) ;

Write(' b=') ;read(b) ;

If (a>0)and(b>0) then k:=0;

If (a>0)and(b<0) then k:=abs(b) ;

If (a<0)and(b>0) then k:=abs(a) ;

If (a<0)and(b<0) then k:=abs(a-b) ;

Write('колво отрицательных чисел ', k) ;

End.

0,0(0 оценок)
Ответ:
еваматвиенко
21.03.2021 22:06

ответ НА ПИТОНЕ ИЛИ С++

Задача 4: Американские горки

Аттракцион «Американские горки» представляет собой рельсовый трек, размещённый на опорах. Известна высота каждой опоры. Для рекламы аттракциона необходимо выделить один из его фрагментов (несколько подряд идущих опор с рельсовым треком) световой подсветкой. При этом необходимо выделить такой фрагмент трека, на котором была бы «горка» то есть на выделенном участке трека была бы точка, которая находилась бы строго выше начала и строго выше конца выделенного фрагмента трека.

Владелец аттракциона для экономии хочет найти подходящий участок минимальной длины, удовлетворяющий условию наличию «горки» на этом участке.

Входные данные

Первая строка входных данных содержит число N – количество опор аттракциона. Следующие N строк содержат информацию о высотах опор при движении от начала к концу аттракциона. Все числа натуральные, не превосходящие 105.

Выходные данные

Программа должна вывести два числа – номер первой и последней подходящей опоры. Опоры нумеруются числами от 1 до N. Если фрагмента, удовлетворяющего условиям, не существует, программа должна вывести одно число 0. Если подходящих ответов несколько, нужно вывести любой из них.

Система оценивания

Решение, правильно работающее только для случаев, когда все входные числа не превосходят 100, будет оцениваться в 40 баллов.

В 100 баллов будет оцениваться решение, правильно работающее, когда все числа не превосходят 105.

Примеры

Ввод Вывод Пояснение

7

18

10

15

20

20

10

3

3 6

Дано 7 опор с высотами 18, 10, 15, 20, 20, 10, 3. Самый короткий участок, содержащий «горку» – это 15, 20, 20, 10. Он начинается опорой номер 3 и заканчивается опорой номер 6.

3

9

8

5

0

Высоты опор убываю

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота