michlich
07.01.2021 16:48

Напишите на Напишите программу, которая находит в массиве номера элементов, равных минимальному. Входные данные

Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные

Программа должна вывести в одной строке номера элементов массива, равных минимальному, разделив их пробелами.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
киреева2
01.02.2021 16:40

#include <iostream>

using namespace std;

int main() {

int N, min;

cin >> N;

int* array = new int[N];

for (int i = 0; i < N; i++)

 cin >> array[i];

min = array[0];

for (int i = 1; i < N; i++) {

 if (array[i] < min)

  min = array[i];

}

for (int i = 0; i < N; i++) {

 if (array[i] == min)

  cout << i << " ";

}

delete[] array;

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота