Studio1
01.01.2023 16:15

Составьте программу на питоне. 1. Найти “МОЖНО”, если L 7.28 , где L вводится.
2. Определить принадлежит ли точка с координатами (x, y) фигуре на плоскости? Фигура –
треугольник с вершинами в точках (0,0), (1,0), (1,1).
3. Расположить числа n1, n2, n3 в возрастающем порядке.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
domofon98
09.11.2022 17:54
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  a.Select(x->2*x).Println
end.

Тестовое решение
n= 10
-52 -23 48 -54 -72 -36 -87 -46 -21 54
-104 -46 96 -108 -144 -72 -174 -92 -42 108

Длинный "школьный" вариант
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
const
  nn=100;
var
  i,n:integer;
  a:array[1..nn] of integer;
begin
  Write('n='); Read(n);
  Randomize;
  for i:=1 to n do begin
    a[i]:=Random(200)-100;
    Write(a[i],' ')
    end;
  Writeln;
  for i:=1 to n do Write(a[i]*2,' ');
  Writeln
end.
0,0(0 оценок)
Ответ:
Sonya2896
30.07.2021 19:03
1.)
16 = 2^4
Получается, что рисунок p2.bmp - четырехразрядный, т.е. 1 пиксель занимает 4 бит памяти. 24/4=6. ответ: в 6 раз.

2.)
64*512=32768 - кол-во пикселей в изображении.
32 Кбайт = 32768 байт.
32768/32768=1 байт = 8 бит - память, занимаемая 1 пикселем.
2^8=256. ответ: 256 цветов.

3.)
25*30 см = 10*12 дюймов = 120 дюймов^2
10*12*300*300*3=32400000 байт = 31640 Кбайт = 30 Мбайт.
ответ: 30 Мбайт.

4.)
65536 = 2^16
1 пиксель занимает 16 бит = 2 байта.
1280*1024*2 = 2621440 байт = 2560 Кбайт = 2,5 Мбайт.
ответ: 2,5 Мбайт.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота