Golpio
13.05.2023 07:33

Решите:
Дано целое трёхзначное число х. Составьте программу вычисления суммы и произведения цифр трёхзначного числа х. Значение х ввести с клавиатуры.
Язык программирования Паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
cnastya970
01.02.2021 01:00

Прости что не текстом :(


Решите: Дано целое трёхзначное число х. Составьте программу вычисления суммы и произведения цифр трё
0,0(0 оценок)
Ответ:
Alinwhite
01.02.2021 01:00

var

s,pr,x : integer;

begin

readln(x);

x := abs(x);

s:= 0;

pr:= 1;

while x > 0 do

begin

s := s + x mod 10;

pr := pr * x mod 10;

x:= x div 10;

end;

writeln('S = ',s);

writeln('PR = ',pr);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота