zab1290
22.03.2023 08:16

Вариант 1

Задание 1, Дано целое число. Напишите программу, которая увеличивает это
число в два раза, если оно положительное, в противном случае возводит его в
Квадрат.
Задание 2. Дано натуральное число, Напишите программу. Если число четное, то
нарисуйте на экране квадрат красный, а если нечетное, то круг синий.
Задание 3. Дано натуральное число. Напишите программу, которая проверяет,
является ли это число трехзначным,​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Mekaxika
02.03.2021 19:31

1.

program z1;

var k: integer;

begin

write ('Введите число: ');

readln(k);

if k > 0 then k:=k*2

else k:=sqr(k);

write('Сейчас число: ',k)

end.

2.

program z2;

uses GraphABC;

var k: integer;

begin

SetFontSize(15);

write ('Введите число: ');

read(k);

write(k);

if k mod 2 = 0 then

begin

SetBrushColor(clred);

FillRectangle(220,140,420,340)

end

else

begin

SetBrushColor(clblue);

FillCircle(320,240,100)

end

end.

3.

program z3;

var k: integer;

begin

write ('Введите число: ');

readln(k);

write((k>99)and(k<1000))

end.

Объяснение:

Условный оператор:

if условие then действие 1 else действие 2

k > 0 - условие проверки числа на положительность (если число больше 0)

k mod 2 = 0 - условие проверки числа на чётность (если число делится на 2 без остатка)

mod - остаток от целочисленного деления

write((k>99)and(k<1000))  - если число трёхзначное, то ответ True, иначе False


Вариант 1Задание 1, Дано целое число. Напишите программу, которая увеличивает эточисло в два раза, е
Вариант 1Задание 1, Дано целое число. Напишите программу, которая увеличивает эточисло в два раза, е
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота