Yanagolko
27.02.2020 16:47

10. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет
на языке программирования питон

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
anvasilovsckay
02.03.2021 15:13

mass = [int(s) for s in input().split()]

k = 0

a = 0

for i in range(len(mass)):

   if mass[i] % 8 == 0:

       a += mass[i]

       k += 1

if k == 0:

   print('NO')

else:

   print(a / k)

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота