NastyKot15246
07.12.2020 20:04

Составьте программу для двигателя 500 шагов и сколько будет в полу шаговом режиме число шагов двигателя (ардуино)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
OwL505
15.02.2022 20:35
Южные материкиК группе Южных материков относятся Южная Америка, Африка, Австралия, обладающие многими общими чертами природы в силу сходства их географического положения и сопряженной истории формирования в составе Гондваны. Особое положение занимает Антарктида. Этот материк расположен целиком в Южном полушарии и является частью распавшейся Гондваны. Как осколок Южного суперконтинента Антарктида имеет явные черты сходства с другими гондванскими материками в строении поверхности (в геологическом строении и рельефе подледной поверхности). Однако особое географическое положение континента определяет многие уникальные черты его природы. В характеристике компонентов природы Южных материков Антарктиде выделяется особое место.Южные материки омываются водами всех океанов, кроме Северного Ледовитого океана. Антарктида не имеет сухопутных границ, как и Австралия, которая ближе всего связана с Евразией через своеобразный мост — острова и мелководные моря и проливы Малайского архипелага, которые традиционно относят к материку Евразии. Африка отделена от Евразии узкими Гибралтарским проливом и Красным морем. На крайнем северо-востоке на Суэцком перешейке граница между этими материками проходит по искусственному сооружению — Суэцкому каналу. Южная Америка граничит с Северной на Панамском перешейке.  Что именно? Пиши подробнее!
0,0(0 оценок)
Ответ:
003Nikitos003
14.10.2022 22:13
Pascal

 var   
n,i,k : integer;    
function Prost (a : integer) : boolean;  //Возвращает true если число простое
var   
i,b : integer;   
r : boolean; 
begin   
r := true;   
i := 2;   
b := a div 2;   
While (i <= b) and (r) do   
begin     
if a mod i = 0 then     
r := false;   
i := i +1;   
end;   
Result := r; 
end;  

function chet (l : integer) : integer; //Определяет кол-во     
var   i,s : integer;                        //возможных произведений 
                                                 // в числовой последовательносьти
                                                 //заданной длины
begin   
  s := 0;   
for i := 0 to k do     
s := s +(k - i);    
result := s;    
end;
begin 
readln (n); 
k := 0;     
for i := 2 to n do   
if prost(i) then begin     
k := k +1;      
//write (i,' '); // Вывод простых чисел(если надо, то раскоменьтить)     
end;   
writeln ();
writeln ('Кол-во простых чисел на диапазоне = ',k); 
writeln ('Кол-во произведений ',k,' различных чисел : ',chet(k));    
end. 

Вроде работает, хотя вероятно есть более эффективный алгоритм.
Единицу не учитывал как простое.
Блок схему рисовать не буду - геморойной, да и не силен я в этом

Просто попытаюсь объяснить алгоритм

1) Мы находим все простые числа на диапазоне от 1 до n
(выполняется функцией (prost), и перебором.
2) Исходя из кол-ва найденных простых чисел мы можем найти кол-во их произведений. Т.к все числа различны и идут в порядке увеличения.
Это делается с функции (chet)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота