Аня5сплюсом
24.10.2020 12:10

Код в Python 1)В группе учится 10 учащихся. Составьте программу определяющую,
найдется ли хотя бы один ученик с оценкой 5 по информатике. Если
такой ученик найдется, определите его место в списке. Если
найдется несколько таких учеников, то выведите на экран
порядковый номер последнего
2)Дан одномерный массив. Определите сумму всех нечетных элементов,
расположенных на четных местах массива

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Huuur
26.04.2023 21:43
Var
  d1,d2,n:integer;
  k,s:longint;
begin
  Write('Введите натуральное двухзначное число: '); Read(n);
  d1:=n div 10; d2:=n mod 10;
  k:=sqr(n); s:=4*(d1*sqr(d1)+d2*sqr(d2));
  Write(n,': ');
  if k=s then Writeln('Квадрат числа (',k,
      ') равен учетверенной сумме кубов его цифр')
  else Writeln('Квадрат числа (',k,
      ') не равен учетверенной сумме кубов его цифр (',s,')')
end.

Тестовое решение:
Введите натуральное двухзначное число: 48
48: Квадрат числа (2304) равен учетверенной сумме кубов его цифр

Введите натуральное двухзначное число: 47
47: Квадрат числа (2209) не равен учетверенной сумме кубов его цифр (1628)

Замечание: На самом деле лишь одно число 48 среди всех двухзначных чисел удовлетворяет условию равенства, так что достаточно просто сравнивать введенное число с 48, чтобы решить задачу )))
0,0(0 оценок)
Ответ:
happymenfeed
26.04.2023 21:43

1.

var a:longint;

begin

  read(A);

  if (a mod 10)=(a div 10) then writeln('цифры одинаковы');

  if (a mod 10)>(a div 10) then writeln('вторая цифра больше');

  if (a div 10)>(a mod 10) then writeln('первая цифра больше');

end.

 

2.

var a,b,c:longint;

begin

  read(A);

  b:=a mod 10;

  c:=a div 10;

  b:=b*b*b;

  c:=c*c*c;

  d:=4*(b+c);

  if sqr(A)=d then writeln('квадрат этого числа равен учетверённой сумме кубов его цифр') else writeln(' квадрат этого числа не равен учетверённой сумме кубов его цифр');

end.


3.

var a,b,c,d:longint;

begin

  read(A);

  b:=a mod 10;

  c:=a div 10;

  d:=c+b;

  if d mod 3=0 then writeln('сумма цифр данного числа кратна 3') else writeln('сумма цифр этого числа не кратна 3');

  if d mod 4=0 then writeln('сумма цифр данного числа кратна 4') else writeln('сумма цифр этого числа не кратна 4');

end.


4.

var a,b,c,d,e:longint;

begin

  read(A);

  b:=a mod 10;

  c:=(a mod 100)  div 10;

  d:=a div 100;

  b:=b*b*b;

  c:=c*c*c;

  d:=d*d*d;

  e:=b+c+d;

  if sqr(A)=e then writeln('квадрат этого числа равен сумме кубов его цифр.') else writeln('квадрат этого числа не равен сумме кубов его цифр.');

end.


5.

var a,b,c,d:longint;

begin

  read(b,a);

  c:=b mod 10;

  d:=b div 10;

  if (c=3)or(d=3) then writeln('в запись этого числа входит цифра 3') else writeln('в запись этого числа не входит цифра 3');

  if (c=a)or(d=a) then writeln('в запись этого числа входит цифра ',a') else writeln('в запись этого числа не входит цифра ',a);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота