Nikodim39
03.01.2021 21:41

PYTON Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
orehskonastia
27.02.2021 22:11

Решение в лоб:

x = int(input())

lucky = x % 10

check = False

x //= 10

while x > 0:

   if x % 10 == lucky:

       check = True

       break

   else:

       lucky = x % 10

   x //= 10

if check == False:

   print("Одинаковых цифр,стоящих рядом нет!")

else:

   print("Есть одинаковые цифры, стоящие рядом!")

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота