vika12325
25.07.2020 02:55

написать программу с цикла(Pascal)


написать программу с цикла(Pascal)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kzizh
07.05.2021 15:00

7 единиц

Объяснение:

Переведем число 1243(10) в 2-ичную систему счисления, при последовательного деления на 2, до тех пор, пока неполное частное не будет равно нулю. В результате будет получено число из остатков деления записанное справа налево.

1243 :  2 =  621 остаток: 1

621 :  2 =  310 остаток: 1

310 :  2 =  155 остаток: 0

155 :  2 =  77 остаток: 1

77 :  2 =  38 остаток: 1

38 :  2 =  19 остаток: 0

19 :  2 =  9 остаток: 1

9 :  2 =  4 остаток: 1

4 :  2 =  2 остаток: 0

2 :  2 =  1 остаток: 0

1 :  2 =  0 остаток: 1

1243(10) = 10011011011(2)

0,0(0 оценок)
Ответ:
leon7771
26.05.2022 04:38

/** libraries */

#include <iostream>

#include <cmath>

#include <vector>

#include <map>

#include <set>

#include <queue>

#include <stack>

#include <algorithm>

/** libraries */

using namespace std;

/** defines */

#define ll long long

#define ld long double

#define yes cout << "YES" << "\n"

#define no cout << "NO" << "\n"

/** defines */

ld func1(ld x, ld y, ld z){

   return 5 * atan(x) - (1/4) * acos(x) * ((x + 3 * abs(x-y) + pow(x,2))/(abs(x-y) * z + pow(x,2)));

}

ld func2(ld x, ld y, ld z){

   return (pow(M_E,abs(x-y)) * pow(abs(x-y),x+y))/(atan(x)+atan(z)) + pow(pow(x,6) + pow(log(y),2),(1/3));

}

signed main() {

   ios_base::sync_with_stdio(false);

   cin.tie(nullptr);

   cout.tie(nullptr);

   ld x,y,z;

   cin >> x >> y >> z;

   cout << func1(x,y,z) << "\n" << func2(x,y,z);

}

P.S если я где-то косякнул по невнимательности, то пишите, исправим

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота