yanakuznetsova9
02.05.2020 16:24

Составить программу, используя двумерные массивы: Найти максимальное число в третьем столбце матрицы​
(Pascal)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
silinadasha
27.02.2021 00:45

var

 a: array[,] of integer;

 m, n, i, j, max: integer;

begin

 Write('Введите размер матрицы M и N: '); ReadLn(m, n);

 SetLength(a, m, n);

 randomize;

 max := - 100;

 WriteLn('Массив:');

 for i := 0 to m - 1 do

 begin  

   for j := 0 to n - 1 do

   begin

     a[i, j] := random(200) - 100;

     Write(a[i, j]:4);

     if (a[i, j] > max) and (j = 2) then max := a[i, j];

   end;

   WriteLn;

 end;

 WriteLn('Максимальное число в третьем столбце матрицы равно ', max);

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота