pointbreakk9
14.09.2021 10:01

Написать программу суммирования отрицательных четных чисел, оканчивающихся на 4 в последовательности 10 целых чисел

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
лаура1446
25.09.2021 15:02

#include <iostream>

using namespace std;

class circle {

public:

   int x, y;

   double r, s;

   circle()

   {        

       x = 0;

       y = 0;

       r = 0;  

   }

   circle( int a = 0, int b = 0, double c = 0 )

   {

       set(a, b, c);        

   }

   void out()

   {

       cout << "Координаты: (" << x << ", " << y << ") Радиус: "<< r << " Площадь: " << endl;        

   }

   void set(int a, int b, double c)

   {

       x = a;

       y = b;

       r = c;

   }    

   void calculate() {

       s = r * r * 3.14159;        

   }

};

 

class sphere : public circle {

private:

   double  v;

   void calculate() {      

       s = 4 * 3.14 * r * r;  

       v = 3.14159 * pow(r, 3);

   }    

public:

   sphere();

   sphere() : circle(circle, double = 1.0);

   sphere (int = 0, int  = 0, double = 1.0) ;

 

 

 

void out()

   {

       circle::out();

       cout << ", радиус: " << r << ", длина: " << ", площадь: " << s;        

   }

};

int main(){

   setlocale(LC_ALL, "ru");

   circle a(2, 15, 4);

   a.out();

   sphere b;

 

   

   system("pause");

   return 0;

}

Объяснение: пойдёт?

0,0(0 оценок)
Ответ:
movnar98
23.06.2020 09:10

Pascal:

1.

var a,b:Integer;

   x:Double;

begin

 writeln('Введите a, b: ');

 readln(a,b);

 x:=a+b;

 writeln(a,'+',b,'=',x);

 x:=a*b;

 writeln(a,'*',b,'=',x);

end.

2.

var a,b:Integer;

begin

 writeln('Введите оценки за две КР: ');

 readln(a,b);

if (a+b)>= 8 then writeln('Молодец!')

else writeln('Подтянись!')

end.

Python:

1.

a, b = int(input('Введите a')), int(input('Введите b'))

x = a+b

print(str(a) + '+' + str(b) + '=' + str(x))

x = a*b

print(str(a) + '*' + str(b) + '=' + str(x))

2.

a, b = int(input('Введите первую оценку')), int(input('Введите вторую оценку'))

if a+b >= 8:

print('молодец!')

else:

print('подтянись!')

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота