ayshatalieva01
20.12.2022 09:46

Написать программу которая считает формулу a+3×b-4×c×(2×a-2×b), где a=1, b=2, c=3. Язык программирования: Pascal. ответ отправьте в текстовом виде.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kotletka223
25.02.2023 21:37
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  var m:=Readinteger('Что ищем?');
  var k:=a.FindAll(x->x=m).Count;
  Writeln('Найдено таких элементов- ',k);
  if k>0 then Writeln('Номер первого такого элемента- ',
    a.FindIndex(x->x=m)+1)
end.

Пример
n= 17
-46 33 -9 -22 14 -46 -6 -3 -7 -18 46 42 -40 -40 0 29 -9
Что ищем? -9
Найдено таких элементов- 2
Номер первого такого элемента- 3
0,0(0 оценок)
Ответ:
Kam54
17.02.2023 14:36
Там где символы не понятные это разделители задач, 3 из 4
program task;
const n=15;
var a:array[1..n] of integer;
i,s,j,first,max: integer;

begin
óñëîâèå À
begin
a[i]:=0+random(15);
write(a[i]:4);
if(i mod 2=0) then
s:=s + a[i];
end;
çàäà÷à Á
begin
a[i]:=0+random(15);
write(a[i]:4);
end;
writeln();
max:=1;
for i:=1 to n do
if a[i]>a[max] then max:=i;
first:=a[1];
a[1]:=a[max];
a[max]:=first;
writeln('Âåêòîð:');
for i:=1 to n do
çà÷à Â
for i:= 1 to 15 do begin
a[i]:= random(20);
write(a[i],' ');
if a[i] > 0 then
end;
writeln;
writeln;
for i:= 1 to 14 do
for j:= i+1 to 15 do
if a[i] < a[j] then begin
max:= a[i];
a[i]:= a[j];
a[j]:= max;
end;
for i:= 1 to 15 do begin
write(a[i],' ');
end;

end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота