green121
24.01.2021 07:29

ПАСКАЛЬ!Надо написать программу,которая возводит в квадрат от 1 до 10 и в той же программе возводит в куб от 1 до 15

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
svilli711
04.02.2021 12:42

Какие команды присваивания составлены правильно?

а) А:=В (верно для Pascal, Delphi)

б) А=В (верно для многих языков программирования, но не всех)

в) А=В+1 (верно для многих языков программирования, но не всех)

г) А+1:=А (не верно)

2. Сколько промежуточных переменных потребуется для того,чтобы переменной А было присвоено значение переменной В, переменной В- значение переменной С, а переменной С- значение переменной А? Запишите соответствующий алгоритм на алгоритмической языке.

t := C

C := A

A := B

B := t

Одна дополнительная переменная

0,0(0 оценок)
Ответ:
lvcenkoirina
31.10.2020 05:33
Program esep;
var input,output:text;
n,i,j,g,nm,ans,t:integer;
ara:array[0..1000]  of integer;
ar,arq:array[0..1000] of integer;
ts,sum,a:integer;
begin assign(input,'f.in');
reset(input);  
assign(output,'f.out');
rewrite(output);
readln(input,a,n);
ans:=10000;
  for i:=1 to n do begin read (input,ar[i]);ts:=ts+2*ar[i];
end;    
if ts<a then writeln(output,'no') else  
begin
ara[1]:=3;
for i:=2 to 15 do
begin
ara[i]:=3*ara[i-1];
end;
 for i:=1 to ara[n] do
begin
if arq[n]<2 then
begin  
inc(arq[n]);
sum:=sum+ar[n];
inc(nm);  
end  else   begin   
g:=n;while arq[g]>1 do
 begin sum:=sum-ar[g]*arq[g];
dec(nm,arq[g]);arq[g]:=0;
dec(g);
end;
 inc(arq[g]);
sum:=sum+ar[g];
inc(nm);
end;
if sum=a then begin
 if nm<ans then ans:=nm;
end;
end;
 if ans>1000 then writeln(output,'yes') else
 writeln(output, ans); 
  end;
close(output);
close(input);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота