Ludmila28041985
05.02.2020 02:43

Написать программу в тетраде на языке Си++, которая будет выводить формулу и значение y=2x+1 при х равном: 1, 3, 7.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
swdw1
19.08.2022 23:21

var

 n, k, s, sa: integer;

 

begin

 k := 0;

 s := 0;

 sa := 0;

 writeln('Введите последовательность, окончание ввода - число 0');

 repeat

   read(n);

   if (n mod 4 = 0) and (n mod 10 = 2) then s := s + n;

   if (n <> 0) and (n < 100) then inc(k);

   sa := sa + n

 until n = 0;

 readln;

 writeln('Сумма чисел, кратных 4 и заканчивающихся на 2, равна ', s);

 writeln('Количество чисел, не больших 100, равно ', k);

 writeln('Сумма последовательности равна ', sa);

 readln

end.

Объяснение:

0,0(0 оценок)
Ответ:
andrey231132
28.04.2022 12:08

program zz1;

var n,n1,n2,n3:integer; //задаем переменные

begin

write('введите заданное трехзначное число');

read(n); //вводим с клавиатуры заданное трехзначное число

n1:=n div 100; //находим первую цифру числа

n2:=(n mod 100) div 10; //находим вторую цифру числа

n3:=n mod 10; //находим третью цифру числа

if (n1 mod 2 = 0)and(n2 mod 2 = 0)and(n3 mod 2 = 0) //проверяем, если все цифры четные, то выводим один ответ, если нет, то другой

then write('все цифры числа четные ') else write('некоторые цифры числа не четные');

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота