zxvgg
21.05.2021 06:56

Составить программу нахождения периметра треугольника используя подпрограмму вычисления длины стороны по теореме Пифагора. Входные данные: a, b, c - ребра параллелепипеда. Выходные данные P - периметр треугольника.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nadiacolupaeva
23.02.2021 09:24
Формула Шеннона: I=log2 N  (I-кол-во инф-ции; N=всё/нужное)

обозначение:
ч - кол-во четвёрок
т - кол-во троек
д - количество двоек
пятёрок нет

по условию   т+д=22
не провалившиеся = ч+22  > log2 3=log2 ((ч+22)/(ч+т))

инф-ный объём сообщения, что тройка = 2 битам  >
   2=log2 ((ч+22)/т)

Имеем систему трёх уравнений с тремя неизвестными:
т+д=22
log2 3=log2 ((ч+22)/(ч+т))
2=log2 ((ч+22)/т)                                >log2 4=log2 ((ч+22)/т)
       Преобразуем:   
система:
т+д=22
3=(ч+22)/(ч+т)
4=(ч+22)/т        >   ч+22=4т

т+д=22
3ч+3т=ч+22
4т=ч+22

т+д=22
3ч+3т=4т
4т=ч+22

т+д=22
3ч=т
12ч=ч+22

т+д=22
3ч=т
ч=2

ч=2                   т=3ч=6                    д=22-6=16
всего:   2+6+16=24  абитуриента
         ответ  24
0,0(0 оценок)
Ответ:
milanaberezova
23.02.2021 09:24

Вот, вроде работает:

Объяснение:

a = int(input("Сколько дней заниматься математикой?"))

b = int(input("Сколько дней заниматься информатикой?"))

c = int(input("Сколько чашек чая выпивать, когда занимаешься математикой?"))

d = int(input("Сколько чашек чая выпивать, когда занимаешься информатикой?"))

n = int(input("Сколько недель будешь заниматься?"))

chashka = 0

n = n*7

while n > 0:

   chashka = chashka + c * a

   n = n - a

   chashka = chashka + d * b

   n = n - b

print(chashka, "чашек чая")

       

       

   

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота