nikita112289
27.06.2022 13:16

PYTHON 3 У Арлана есть N шариков красного и синего цвета. Каждый шарик имеет свой вес Mi. Для удобства вес красных шариков будем обозначать положительным числом, а вес синих шариков – отрицательным. Вес шарика не может быть нулевым. Арлан хочет украсить новогоднюю ёлочку парами шариков синего и красного цвета одного веса ему определить, сколько пар можно составить из имеющихся шариков.

Входные данные

В первой строке дано натуральное число N, не превосходящее 100000.

Во второй строке даны N целых чисел Mi. Все числа по модулю не превышают 100.

Выходные данные

Выведите одно число – количество возможных пар.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Единорожка2306
29.05.2020 00:30

1. Умножить на 2 2. вычесть b

Выполняя первую из них ,Вычитатель увеличивает число на экране в 2 раза ,а выполняя вторую,уменьшает это число на d.Программа для исполнителя Вычитатель - это последовательность номеров команд.Известно,что программа 22122 переводит число 30 в число 0.Определите значение b (b≥2).

30-x)-x)*2)-x)-x)=60-4x-x-x=60-2x

60-2x=0

-2x=-60

2x=60

x=30

ответ 30

1. Прибавь 1 2.возведи в квадрат

Исполнитель работает только с натуральными числами .Составьте алгоритм получения из числа 1 числа 100,содержащий не более 5 команд

1+1)+1)^2)+1)^2)=3^2=9+1=10^2=100

11212

ответ 11212

Объяснение:

0,0(0 оценок)
Ответ:
artemkafire2005
10.11.2021 05:39

class Program

   {

       struct cr

       {

           public double x, y, l;

       };

       static void Main(string[] args)

       {

           cr[] pn = new cr[3];

           double p = 0;

           for (int i = 0; i < 3; i++)

           {

               Console.Write("Введите X{0}:", i + 1);

               pn[i].x = Double.Parse(Console.ReadLine());

               Console.Write("Введите Y{0}:", i + 1);

               pn[i].y = Double.Parse(Console.ReadLine());

           }

           for (int i = 0; i < 3; i++)

           {

               if (i < 2)

                   pn[i].l = Math.Sqrt((pn[i].x - pn[i + 1].x) * (pn[i].x - pn[i + 1].x) +

                                       (pn[i].y - pn[i + 1].y) * (pn[i].y - pn[i + 1].y));

               else

                   pn[i].l = Math.Sqrt((pn[i].x - pn[0].x) * (pn[i].x - pn[0].x) +

                                       (pn[i].y - pn[0].y) * (pn[i].y - pn[0].y));

               p += pn[i].l;

           }

           Console.WriteLine("Периметр P={0}", p);

           p /= 2;

           Console.WriteLine("Площадь  S={0}",  

               Math.Sqrt(p * (p - pn[0].l) * (p - pn[1].l) * (p - pn[2].l)));

           Console.ReadKey();

       }

   }

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота