oksana1382
20.08.2020 07:13

Напишите программу, в которой вы берете у пользователя два целых числа n и m. Создайте динамический двумерный массив arr2d указателей на числа с плавающей запятой nxm. Для каждого элемента массива с вероятностью 70% зарезервируйте память для одного значения с плавающей запятой и инициализируйте указанное значение случайным числом между

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
AriPanowa2005
17.12.2022 00:24
#include
необходим для подключения заголовочных файлов из стандартной библиотеки C/C++ (в этом случае название заголовочного файла указывается в угловых скобках, например, #include <cstdlib>) или заголовочных файлов сторонних библиотек (в этом случае название указывается в двойных кавычках, например, #include "sqlite3.h").

using namespace std
используется для выбора пространства имён std по-умолчанию. В библиотеках могут быть использованы различные пространства имён, ограничивающие область видимости функций, классов и глобальных переменных. В стандартной библиотеке используется пространство имён std, указывающее на то, что данная конструкция является частью стандартной библиотеки. Если не использовать никакое пространство имён, то даже при подключении заголовочного файла (например применив вызов #include <iostream>), мы не сможем явно использовать элементы этой библиотеки, которые объявлены в пространстве имён std. Т.е. вызов cout << "Привет, мир!" вызовет ошибку, что объект cout не найден. Это происходит потому, что данный объект имеет область видимости только внутри пространства имён std. Но мы можем его вызвать, явно указав, в каком пространстве имён следует искать данный объект. Для этого необходимо перед именем объекта указать имя пространства имён, в котором он находится. Пример:

#include <iostream>

int main()
{
     cout <<"Hello!"  // Ошибка - не указано пространство имён
     std::cout  <<"Hello!"  // Нет ошибки - вызов объекта из пространства имён std, указанного явным образом
}

как-то так...
0,0(0 оценок)
Ответ:
Elizabeth041100
28.02.2023 07:53
Честно, не поняла ваш код вообще. Почему нет цикла? Предлагаю свое решение:
1)Cначала заполняем массив случайными числами от 2 до 5 (включительно)
2)Потом выводим его (Для проверки)
3) Потом считаем оценки. Но сначала нужно обнулить переменные( В самом начале это делали), а то получится кака (:

program N_0547847;
var
    b, c, d, f, i:integer;
    a: array [1..20] of integer;
begin;
randomize;
b:=0; c:=0; d:=0; f:=0;
for i:=1 to 20 do begin
  a[i]:=random(4)+2; 
  write(a[i],' '); end; 
writeln;
for i:=1 to 20 do begin
    if a[i]=2 then  b:=b+1;
    if a[i]=3 then  c:=c+1;
    if a[i]=4 then  d:=d+1;
    if a[i]=5 then   f:=f+1;
end;
writeln('Двоек: ', b); 
writeln('Троек: ', c); 
writeln('Четверок: ',d);
writeln('Пятерок: ',f);
end.   
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота