daryabatova
29.09.2021 10:46

Pascal (домашнее задание) мелкая программа составить программу которая будет выполнять данные числа и выводить результаты на экран.

1) 8!=1*2*3*4*5*6*7*8

2) 2⁵=2*2*2*2*2

Команды часто используемые: For i:

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
denisst105
23.09.2020 23:20
Программа, которая использует два массива

var 
c, a: array[1..20] of integer; 
i: integer;
begin 
write('Первый массив '); 
for i := 1 to 20 do   begin   
c[i] := i * (-5);   
write(c[i], ' '); 
end; 
writeln; 
write('Преобразованный массив '); 
for i := 1 to 20 do   begin   
a[i] := c[20 - i + 1];   
write(a[i], ' '); 
end;  
end.

ИЛИ  Программа не использующая два массива, а просто переворачивающая первый

var 
c: array[1..20] of integer; 
i: integer;
begin  write('Первый массив '); 
for i := 1 to 20 do   begin   
c[i] := i * (-5);   
write(c[i], ' '); 
end; 
writeln; 
write('Преобразованный массив '); 
for i := 20 downto 1 do  write(c[i], ' '); 
end.

Обе программы работают!
0,0(0 оценок)
Ответ:
Белялова
28.08.2021 05:39
Для удобства вычислений переведём размер сканируемого изображения в дюймы: 20,32 × 20,32 (см) = 8 × 8 (inch).

Сначала найдём количество пикселей по горизонтали, по вертикали, затем общее количество пикселей, исходя из разрешающей сканера. Зная, что каждый пиксель кодируется 4 битами, найдём объём памяти, необходимый  для хранения графической информации, что и будет являться информационным объёмом файла.

1)    600 × 8 = 4800 (px) – количество пикселей по горизонтали.

2)    1200 × 8 = 9600 (px) – количество пикселей по вертикали.

3)    4800 × 9600 = 46 080 000 (px) – всего пикселей.

4)    46 080 000 × 4 = 184 320 000 (bit) = 22 500 (KB)

ответ: полученный графический файл будет иметь объём 22 500 килобайт.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота