topalinskaya
18.02.2023 02:08

Написать программу на паксале. Имеется последовательность натуральных чисел, число элементов которой нечётно. Ноль – признак конца и в число элементов последовательности не входит. Определите, является ли среднее из чисел последовательности больше среднего арифметического данной последовательности, и выдайте полученный результат в виде YES | NO. При решении задачи допустимо использование массивов.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
milanakalinovskaya
02.09.2022 01:01

C++ (Qt)Выделить код

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

56

57

58

59

60

#include <stdio.h>

#include <tchar.h>

#include <iostream>

#include <algorithm>

#include <vector>

using namespace std;

 

class group

{

   char** family;

   int** ball;

   int max_i;

public:

   group();

   void set_family(char* s);

   void set_balls(int* s, int i);

   void get_list();

};

group::group()

{

   group::max_i = 0;

   group::family = new char* [255];

   group::ball = new int* [255];

}

void group::set_family(char* s)

{

   group::family[group::max_i] = new char[255];

   group::family[group::max_i] = s;

}

void group::set_balls(int* s, int i)

{

   group::ball[group::max_i] = new int[i + 1];

   group::ball[group::max_i][0] = i;

   for (int j = 1; j < i; j++)

       group::ball[group::max_i][j] = s[j - 1];

   group::max_i++;

}

void group::get_list()

{

   int tmp = 0;

   double buf = 0;

   for (int i = 0; i < group::max_i; i++)

   {

       cout << group::family[i] << endl;

       tmp = group::ball[i][0];

 

       for (int j = 1; j < tmp; j++)

           buf += group::ball[i][j];

       buf /= tmp;

       cout << buf << endl;

       cout << "" << endl;

       buf = 0;

       tmp = 0;

   }

}

int main()

{

   

   cout << "Тут";

}

0,0(0 оценок)
Ответ:
EvelEvg
04.04.2023 08:47

Объяснение:

Компьютерная графика — это графическое фото- или видеоизображения, которые созданы в специальных программах на компьютерах. Машинная графика может создаваться на компьютерах изначально, а может получаться после сканирования и перевода объектов реального мира в цифровую форму. Графика применяется везде: в интернете на веб-страницах, в компьютерных играх, в спецэффектах в фильмах, на фотографиях, в различных схемах и графиках, в презентациях, в анимации, в системах автоматизированного проектирования (САПР) и др.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота