vanykazakoff
23.06.2020 15:32

Python. Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. Необходимо определить количество автомобилей, скорость которых не превышала 30 км/ч.

Программа получает на вход число проехавших автомобилей N (1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести количество автомобилей, скорость которых не превышала 30 км/ч.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nick313
06.04.2021 20:35
Сумма номеров от 1 до 9 равна 45.
Сумма от 10 до 19 равна 10 + 45 = 55.
Сумма от 20 до 29 равна 2*10 + 45 = 65.
Сумма от 30 до 39 равна 3*10 + 45 = 75.
...
Сумма от 90 до 99 равна 9*10 + 45 = 135.
Сумма всех цифр от 1 до 99 равна
45 + 55 + 65 + ... + 135 = (45 + 135)*10/2 = 180*10/2 = 900
В номерах от 100 до 199 та же сумма цифр 900 + 100*1 = 1000
В номерах от 200 до 209 сумма цифр 2*9 + 45 = 18 + 45 = 63
В номерах от 210 до 212 сумма цифр 2+1+0+2+1+1+2+1+2 = 12
Итого сумма всех цифр 900 + 1000 + 63 + 12 = 1975
0,0(0 оценок)
Ответ:
LoliTyan1
31.01.2023 00:41
1.
n = int(input("N="))
heads = n * 3 if n <= 100 else 100 * 3 + (n - 100) * 2
eyes = heads * 2
print(heads)
print(eyes)
2. Используется прямая формула для н-ого члена
for x in range(1, 9):
  print(int((1/(5**0.5))*1+5**0.5)/2)**x)-(((1-5**0.5)/2)**x
3.
try:
  num = int(input("N="))
except ValueError:
  print('Not a number')
if num > 2000000:
  print('too big')
else:
  print(len(str(num)))
5.
a = abs(int(input('a=')))
b = abs(int(input('b=')))
while a!=0 and b!=0:
    if a > b:
        a %= b
    else:
        b %= a
print(a + b)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота