NasTieZ31
07.07.2022 19:10

В Паскале составить программу по смене значений 6 переменных поменять местами
на входе: 123456
на выходе: 631542

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Я вам уже же дал пример, могли бы сами под себя подстроить, вот, ловите:\\
var input, num, nulls, positive, negative, i: integer;
begin
write('Введите кол-во чисел: ');
readln(input);
for i := 1 to input do begin
  write('Введите число номером ', i, ': ');
  readln(num);
  if num = 0 then inc(nulls, 1);
  if num < 0 then inc(negative, 1);
  if num > 0 then inc(positive, 1);
end;
writeln('Кол-во нулей: ', nulls);
writeln('Кол-во положительных чисел: ', positive);
writeln('Кол-во отрицательных чисел: ', negative);
end.
0,0(0 оценок)
Ответ:
4elo100
10.04.2022 00:50
Камера не очень, так что спрашивай, если непонятно что-то.
____________________________________________________ 
В первом номере деление на триады для восьмеричной - сверху, а для шестнадцатеричной - снизу (см. дуги около числа в двоичной записи).
Во втором номере слева исходный пример, а справа в десятичной записи(подразумевалось, что числа сам можешь перевести из (2) в (10) ). Потом ниже проверка.
В третьем а) можно было умножать на 16, а можно через двоичную. Я сделала через двоичную.
В четвертом, как  и в первом, деление на восьмеричные триады - сверху, на шестнадцатеричные - снизу.
1.перевести данное числно из десят ичной системы счисление в двоичную,восьмеричну.шестандцатеричную
1.перевести данное числно из десят ичной системы счисление в двоичную,восьмеричну.шестандцатеричную
1.перевести данное числно из десят ичной системы счисление в двоичную,восьмеричну.шестандцатеричную
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота