HoneyAmy
19.01.2022 03:18

Напишите и протестируйте программу. Поиск максимального элемента массива. Сначала создается сам массив (в этом примере это целые числа от 0 до 100 включительно). Program Max_element_massiva ;
Var i, n, max : integer ;
A : array [1..100] of integer;
Begin
Writeln('Введите количество элементов массива') ;
Readln(N) ;
Randomize;
For i := 1 to N do
begin
A[i] := Random(100);
Write(A[i]);
end;
Max := A[1];
For i := 2 to N do
if A[i]>Max then Max := A[i];
Writeln('Максимальный Элемент массива = ',Max) ;
Readln ;
End.
с решение

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Dupper2356
21.03.2020 00:43

C WF не работал, вот что получилось:


using System;

using System.Collections.Generic;

using System.ComponentModel;

using System.Data;

using System.Drawing;

using System.Linq;

using System.Text;

using System.Threading.Tasks;

using System.Windows.Forms;

namespace WindowsFormsApp3 {

       public partial class Form1 : Form {

            public Form1() {

                 InitializeComponent();

                 textBox1.TextChanged += textBox1_TextChanged;

            }

            private void textBox1_TextChanged(object sender, EventArgs ee) {

                 string res;

                 string[] ed = new string[10] { " ","один", "два", "три", "четыре", "пять", "шесть", "семь", "восемь", "девять" };

                 string[] des = new string[10] { " ",      "десять","двадцать","тридцать","сорок","пятьдесят","шестьдесят","семьдесят", "восемьдесят","девяносто" };

                 string[] sot = new string[10] { " ", "сто", "двести", "триста", "четыреста", "пятьсот", "шестьсот", "семьсот", "восемьсот", "девятьсот" };

                 string[] iskl = new string[10] { " ",      "одинадцать","двенадцать","тринадцать","четырнадцать","пятнадцать","шестнfдцать","семнадцать","восемьнадцать","девятнадцать" };

                 int x;

               if ((int.TryParse(textBox1.Text, out x)) && (x >= 0) && (x <= 1000))

                 {

                      if (x == 1000) res = "тысяча";

                      else if (x == 0) res = "ноль";

                      else {

                         int s = x / 100; x= x % 100; res = sot[s];

                         int d = x / 10; int e = x % 10;

                         if ((d == 1) && (e != 0)) res = res + " " + iskl[e];

                         else res = res + " " + des[d] + " " + ed[e];

                      }

                      label1.Text = res;

                 }

                 else label1.Text="";

           }

       }

}


Код и пример формы в приложении.


Написать программу, которая для любого трехзначного натурального числа печатает его на естественном
0,0(0 оценок)
Ответ:
Винасуэлла
31.01.2023 16:07
Существует три философские концепции информации:

1.Атрибутивная концепция опирается на наиболее широкое понимание информации как отражения разнообразия в любых объектах и процессах как в живой, так и в неживой природе. В ней информация в самом общем виде определяется как мера неоднородности распределения материи и энергии в пространстве и времени, которая сопровождает все протекающие в мире процессы.

2.Функциональная концепция - Форма отражения, которая связана с самоуправляемыми системами. В данном контексте информация интерпретировалась не как свойство всей материи, но как особенность живых самоуправляющихся систем или же сознательных существ, как основная предпосылка и условие оптимального управления.

3.Антропоцентрическая концепция информация существует лишь в человеческом сознании, в человеческом восприятии. Информационная деятельность присуща только человеку, происходит в социальных системах. Создавая информационную технику, человек создает инструменты для своей информационной деятельности.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота