кгшкванек1991
29.10.2022 22:15

с информатикой, все на языке программирования python 1) Среди 3-х значных чисел найдите числа у которых встречается в записи два раза цифра 5. Напечатайте эти числа.
(Например: 155, 505, 551 955 ...)

2) введите 3-х значное число. Составьте программу вычисления произведения цифр этого 3-х значного числа.
Например:
А=123
ответ: 6
(смотрите задачу нахождения суммы цифр числа)

3) Задайте 3 числа. Первое число увеличите в 2 раза, второе число уменьшите в 4 раза, к третьему числу прибавьте произведение первого и второго чисел. Напечатайте эти три числа.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Vanya2155
19.02.2021 21:05

1.

a = [155, 200, 255, 525, 551, 955, 908]  # Список 3-х значных чисел

b = []

for i in a:

   c = list(str(i))

   if c.count('5') >= 2: b.append(i)

print(*b)

2.

a = int(input())

b = 0

while a != 0:

   b = b + a % 10

   a = a // 10

print(b)

3.

a = [int(input(f'{i+1}е число:')) for i in range(3)]

b = [a[0] * 2,a[1] / 4,]

b.append(a[2] + b[0] + b[1])

for j,i in enumerate(b,1):

   print(f'{j}е число:',i)

0,0(0 оценок)
Ответ:
nikgolubev2000
19.02.2021 21:05

1. что-то типа

>>> incoming = [505, 155, 955,550, 433, 234, 23, 1, 45, 55]

>>> result = [i for i in incoming if len(str(i)) == 3 and str(i).count('5') == 2]

>>> print(result)

[505, 155, 955, 550]

2. мне кажется можно сделать лучше чем:

>>> incoming = [505, 155, 955,550, 433, 234, 23, 1, 45, 55]

>>> f = lambda x, y, z: int(x) * int(y) * int(z)

>>> res = [f(*list(str(i))) for i in incoming if len(str(i)) == 3]

>>> print(res)

[0, 25, 225, 0, 36, 24]

3. Не думаю что это задача

>>> a, b, c = 1, 2, 3

>>> res = [a*2, b/4 if b != 0 else 0, a*b+c]

>>> print(res)

[2, 0.5, 5]

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота