ilya1613
28.10.2021 21:01

ИНФОРМАТИКА 10КЛ составить программу
Д=5-4x/10

Д=5-4x^2/10x

E84 (5 - а) ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DonP3dro
18.05.2021 15:34
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var n:=ReadInteger('Введите четырехзначное число');
  Writeln('В числе');
  Writeln(n div 1000,' - тысяч');
  Writeln((n div 100) mod 10,' - сотен');
  Writeln((n mod 100) div 10,' - десятков');
  Writeln(n mod 10,' - единиц')
end.

Тестовое решение:
Введите четырехзначное число 4072
В числе
4 - тысяч
0 - сотен
7 - десятков
2 - единиц

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var n:=ReadInteger('Введите трехзначное число');
  var s:=n div 100;
  var d:=(n div 10) mod 10;
  var e:=n mod 10;
  Writeln('Sum=',s+d+e);
  Writeln(e,d,s);
  Writeln('В числе');
  Writeln(e,' - сотен');
  Writeln(d,' - десятков');
  Writeln(s,' - единиц')
end.

Тестовое решение:
Введите трехзначное число 492
Sum=15
294
В числе
2 - сотен
9 - десятков
4 - единиц
0,0(0 оценок)
Ответ:
Vanya2155
14.02.2023 16:00
Pascalabc.net var   a: array[1..10000] of integer;   kz,maxp,n,i,j: integer;   begin     i: =0;   maxp: =integer.minvalue;   writeln ('готов к приему чисел');   repeat     i: =i+1;     readln (a[i]);     until a[i]=0;   n: =i-1;   readln (kz);   for i: =1 to n-1 do      for j: =2 to n do        if maxp< (a[i]*a[j]) then maxp: =(a[i]*a[j]);     writeln ('получено ',n,' чисел');   writeln;   writeln ('полученное контрольное значение: ',kz);   writeln;   writeln ('вычисленное контрольное значение: ',maxp);   writeln;   if kz=maxp      then writeln ('контроль пройден')     else writeln ('контроль не пройден'); end. результаты: 1) готов к приему чисел 1 2 3 4 5 0 20 получено 5 чисел полученное контрольное значение: 20 вычисленное контрольное значение: 20 контроль пройден 2) готов к приему чисел 1 2 3 4 5 6 0 20 получено 6 чисел полученное контрольное значение: 20 вычисленное контрольное значение: 30 контроль не пройден
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота