Eyre
05.03.2022 02:47

С клавиатуры вводится символ. Составить программу, которая будет определять является ли считанный символ цифрой или нет. В случае, если это цифра, выводится слово заменяющее ее числовое представление, в противном случае выводится фраза "Введенные данные не относятся к цифре"

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nezervillager
28.10.2020 17:37
Ну почему,когда просят написать программу никто никогда не указывает язык программирования.я напишу на языке паскаль с входным и выходным файлом,но если это не тот язык,твоя проблема.(сообщения в фигурных скобках,это комментарии,просто для пояснение,можешь удалить их)

program p1;
const n=10;
var a : array[1..n] of integer;
i,b,c:integer;
begin 
randomize; 
assign(input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);

for i:=1 to n do {Заполнение исходного массива}   
a[i]:=random(21)-10;
  
for i:=1 to n do {Вывод исходного массива(можно удалить эти строчки)}
write(a[i]:4);

c:=0; {Инверсия массива} 
for i:=1 to 2 do  begin   
b:=a[i];   
a[i]:=a[5-c];   
a[5-c]:=b;   
c:=c+1; 
end; 
c:=0; 
for i:=6 to 8 do 
begin   
b:=a[i];   
a[i]:=a[10-c];   
a[10-c]:=b;   
c:=c+1; 
end; 
writeln;
  
for i:=1 to n do {Вывод инверсированого массива} 
write(a[i]:4);

close(input);
close(output);
end.
0,0(0 оценок)
Ответ:
vitalinabelova1
01.01.2020 08:17
Во первых хочу заметить, что в реальном мире однозначно односторонних не бывает, особенно если дело касается живого

 1) Источник: учебник Приемник: школьник.
 2) Источник: письмо Приемник: бабушка.
 3) Источник: будильник Приемник: мальчик.
 7) Источник: газета Приемник: человек.
 8) Источник: лист изменений Приемник: ученики. ??
10) Источник: знак Приемник: водители
11) Источник: билет Приемник: мальчик.
Все эти ситуации однотипные, односторонние по типу. Хотя конечно приемник может влиять на книгу/газету и тп, но информация в ней от этого не изменится

 9) Источник: диспетчер. Приемник: пассажиры. ??
Вообще говоря случай односторонний, но возможно влияние на то что скажет диспечер. Например кто-то придет и скажет, что потерял ребенка и диспечер объявит об этом на всю станцию.

 4) Источник: Таня, Лена Приемник: Таня, Лена. Двусторонний (и так все понятно)
 5) Источник: учитель Приемник: класс
Впринцепе односторонний, но ученики могут задавать вопросы. Тут скорее двустороний подчиненный, без разрешения учителя, ученики ничего не говорят. С другой стороны учитель смотрит, как его слушают ученики, считывает настроение класса, тп
 6) Источник: регулировщик Приемник: водители, пешеходы
Это все-таки двусторонний процесс, регулировшик следит за машинами и ситуацией, решает как лучше разрулить ситуацию, а окружающие слушаются его команд.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота