dymovvla01928
26.02.2021 17:37

Написать программу на пайтоне(см. подробности) Рассматривается множество целых чисел, принадлежащих числовому отрезку [4197; 9182], которые делятся на 5 и не делятся на 6, 10, 13, 16. Найдите количество таких чисел и максимальное из них. В ответе запишите два целых числа без пробелов и других дополнительных символов: сначала количество, затем максимальное число.

Для выполнения этого задания напишите программу.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Мыркпвы
20.06.2021 17:18
Первая программа:

Var
   A:integer;
   P:real;
Begin
P:=1;
For A:= 100 to 405 do
    if A mod 13 = 0 then P:=P*A;
WriteLn('P = ',P);
End.

Результат работы программы:
P = 8.85587927807922E+56

Вторая программа:

Var
   A:integer;
   P:real;
Begin
P:=1;
For A:= 11 to 36 do
    if A mod 2 = 0 then P:=P*A;
WriteLn('P = ',P);
End.

Результат работы программы:
P = 4.37068711644365E+17

Третья программа:

Var x:real;
Begin
WriteLn('y(x) = 5*x +6');
x:=1;
Repeat
WriteLn('y(',x:0:3,') = ',5*x+6);
x:=x+0.4
Until x>4;
End.

Результат работы программы:
y(1.400) = 13
y(1.800) = 15
y(2.200) = 17
y(2.600) = 19
y(3.000) = 21
y(3.400) = 23
y(3.800) = 25
0,0(0 оценок)
Ответ:
Aind1
20.06.2021 17:18

1)      а:=b(13)+a(-2)*3=13+(-2*3)=13-6=7

2)      a) readln(а); readln(х);

б) writeln(z)

в)    var b,c : real; (чаще всего используется при нахождении вещественных чисел)

        var a: integer; (чаще всего используется при нахождении вещественных чисел)

г) if d = a(число, которому нужно прировнять, этот фрагмент цикла(если…,то ..иначе)) then d:=d+20; д) z := x + y; ( : = это знак присвоения)
3) 

PROGRAM PR1;

var w,s,b: integer;

BEGIN

READLN (S, B);

w:= ((12*s) + (26*b));

WRITELN (W);

end.
4) Запишите на языке Паскаль следующие условия:
а) f >105 ;
б)  a<184  ;
в)  w<>181;  
г)  z>0;
д) z<=d;
е) (y*x)>=(d+w);
ж)  (w-d)<88;
з) f>=1;
5. Запишите на языке Паскаль команду ветвления для решения следующей задачи:

а) if  a<> 21 then a:=a+28 else a:=a-51;
б) if  a mod  2=0 then a:=a+5 else a:=a-12;

6. Запишите на языке Паскаль команду цикла для решения следующей задачи:
а)  PROGRAM PR1;
var j,p: integer;
BEGIN j:=1; p:=0;
While j>=66 do BEGIN p:= p*j; j:=j+1:
WRITELN (‘произведение чисел = ‘, p);
end.
б)  

PROGRAM PR1;

var n:integer;

begin

for n:=1 to 7 do

writeln('trud');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота