KOTE422
20.02.2020 20:49

Составить программу на языке паскаль по условию: если х>=3 то у=6*х2, иначе у=-2*х надо.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
anyta03
02.08.2021 01:24

#include <iostream>

using namespace std;

const int N = 6;

int min, max,srednee;

int main()

{

int arr[N];

min = 15001;

max = -1;

for (int i = 0; i < N; i++)

{

 cin >> arr[i];

}

for (int i = 0; i < N; i++)

{

 if (arr[i] % 2 == 0)  

 {

  if (arr[i] < min)

   {

    min = arr[i];

   }

  if (arr[i] > max)

   {

    max = arr[i];

   }

 }

}

srednee = (min + max) / 2;

for (int i = 0; i < N; i++)

{

 arr[i] = arr[i] - srednee;

 cout << arr[i] << endl;

}

return 0;

}

0,0(0 оценок)
Ответ:
pudgenamide
01.07.2022 17:46

Объяснение:

У мальчика Пети обычный старый телефон.

Скорость потока данных, который будет поступать в его телефон зависит не только от разрешения видео, но также и от кодека, которым видео закодировано, частоты кадров,  и силы сжатия видео- и аудиоряда (с потерей качества).

Рассмотрим некий стандартный вариант для видео 320х240 пикс.  с частотой кадров 25 кадр/сек и качеством звука 128 кбит/сек.

Для таких параметров скорость потока данных  будет составлять: 225+128 кбит/сек=353 кбит/сек.

Умножаем 4 часа на 60 минут на 60 секунд на 353 кбит/сек:

4*60*60*353=5083200 кбит за 4 часа или 635400 кбайт.

(Тут следует уточнить, что автор вопроса неверно указал в задании объём данных как "Гб" , так как буква "б" - маленькая, то Гб - это Гигабит!, а в таких единицах измеряется не объём, а скорость передачи данных, поэтому я взял на себя смелость считать, что имеется в виду "ГБ" - гигабайты)

Дальше начинаются юридические нюансы, связанные с тем, где проживает автор вопроса.

Согласно ГОСТ 8.417—2002 термин гигабайт с обозначением «ГБ» равен 10⁹ = 1 000 000 000 байт. Этим ГОСТом пользуется РФ и некоторые страны бывшего СССР; во всём остальном мире принято считать, что, согласно решению международной комиссии IEC гигабайт равен 2³⁰ = 1 073 741 824 байт.

Допустим, задача решается для жителя РФ. Тогда

635400 кбайт = 635400/1000000=0,6354 ГБ за 4 часа или

1) ≈0,159 ГБ за 1 час.

Посчитаем трафик Пети за месяц длиной в 31 день при идеальной связи без обрывов:

0,6354*31=19,6974 ГБ/мес. (т.е опасения Пети верны. Его трафика хватит только на 4-5 дней)

2) На этот вопрос ответ однозначный. Постоянная перезагрузка видео сервисом Ютьюб будет увеличивать трафик, т.к. кешируется только около 30 секунд видео. Гораздо выгоднее было бы закачивать серию целиком с программы типа download-manager, а затем просматривать ее уже с локального носителя, а не напрямую из интернета.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота