Gibiskus2
13.12.2021 14:10

Что такое массив? как объявляется массив?
какие типы данных может содержать массив?
опишите массив(имя,количество,символов,тип элементов)​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Qwer3313qw
04.04.2021 08:25

Рассмотрим решение

Объяснение:

Итак, задача состоит в том, чтобы переставить слова, разделенные пробелом, этим и будем пользоваться.

На вход получим строку s, где слова разделены пробелом. Запишем все слова, разделенные пробелом, в список lis_s с list comprehensions.

В список rub запишем все элементы из списка lis_s в обратном порядке - в этом нам уменьшающийся range (шаг -1).

Так как требуется строка, а не список, то введем новую строку new_string, которая и будет являться результатом.  В цикле for будем прибавлять к ней каждый элемент списка rub. Однако мы столкнемся с некоторой проблемой: слова не будут разделены. Тогда будем добавлять пробелы после каждого слова. Но и здесь ждет подвох: так мы добавим пробел и после последнего слова, тем самым изменив длину данной нам сначала строки. Выход: введем переменную bad_count, в каждой итерации цикла for будем прибавлять к ней 1, пока значение bad_count не совпадет с длиной списка rub. Как только это случится, пробел мы не прибавим.

Подробное решение приведено на скриншоте.


Составить программу, которая изменяет последовательность слов в строке на обратную. ПИТОН НАПРИМЕР в
0,0(0 оценок)
Ответ:
AikolNur
03.02.2022 12:00

const n=5;

procedure Swap(var a,b:integer);

var tmp:integer;

begin

tmp:=a;

a:=b;

b:=tmp;

end;

var a:array[0..n-1,0..n-1] of integer;

   i,j,k:byte;

   x:integer;

begin

writeln('Исходная матрица:');

for i:=0 to n-1 do

begin

 for j:=0 to n-1 do

  begin

   read(a[i][j]);

  end;

end;

for i:=0 to n-1 do

begin

 for j:=0 to n-1 do

  begin

   write(a[i,j]:3);

  end;

 writeln;

end;

//сортировка всей матрицы по возрастанию

for i:=0 to n*n-2 do

for j:=i+1 to n*n-1 do

if a[i div n,i mod n]>a[j div n,j mod n]

then Swap(a[i div n,i mod n],a[j div n,j mod n]);

writeln('Отсортированная матрица по возрастанию');

for i:=0 to n-1 do

begin

 for j:=0 to n-1 do

 write(a[i,j]:3);

 writeln;

end;

end.

// РЕШЕНИЕ ЗАДАЧ Telegram: @Vadukk

Объяснение:


ПАСКАЛЬ. Создать двумерный массив, ввести с клавиатуры значения и отсортировать их в порядке возраст
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота