anastasiyaryum1
05.05.2020 18:28

ИНФОРМАТИКА. ПАСКАЛЬ(ЯЗЫК ПРОГРАММИРОВАНИЯ) Задача 1. Создайте программу, определяющую, какой сейчас сезон по введённой температуре воздуха:от 0 до -30 0С – зима; от +20 до +40 0С – лето; иначе (от +1 до +19 0С) - весна или осень.

Задача 2. Составить программу, вычисляющую стоимость покупки с учетом скидки: если покупка превышает 1500 р., то начисляется скидка 3%, если превышает 2000, то начисляется скидка 5%. Выше 4000 - скадка 7%. На вход - стоимость покупки, выход - сколько нужно оплатить.

Решать по такому типу:

a,b,c:integer;
begin
writeln('Введите три числа: '); readln(a,b,c);
if (a>b) and (b>c) then
writeln(a,b,c);
if (a>b) and (b>c) then writeln(c,b,a);
if (a>c) and (c>b) then writeln(b,c,a);
if (b>a) and (a>c) then writeln(c,a,b);
if (b>c) and (c>a) then writeln(a,c,b);
if (c>a) and (a>b) then writeln(b,a,c);
if (c>b) and (b>a) then writeln(a,b,c);
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
infaitile
18.01.2021 12:50

первая задача ответ-var x: real;

begin

writeln('введите температуру');

readln(x);

if (x>=-30) and (x<=0) then writeln('зима')else

if (x>=20) and (x<=40) then writeln('лето') else

writeln('весна или осень')

end.

Объяснение:

думаю правельно

0,0(0 оценок)
Ответ:
57788
18.01.2021 12:50

тут нада зробити у програмі Рутсон и написати оце потім візьмеш нажмеш ран и побачиш результат

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота