Criss666
16.05.2023 11:46

1. Написать программу на VBA, реализующую следующий алгоритм: Радиус шара S=4πR2

Рассчитать радиус для введенного R

2. Написать программу на VBA, реализующую следующий алгоритм:

Написать программу для расчета стоимости абонемента.

Стоимость билета 1000 рублей

При покупке 3х билетов, предоставляется скидка 10%

При покупке 4-7 билетов – скидка 20%

При покупке более 7 билетов – скидка 30%

Вводится количество билетов. Выводится общая стоимость билетов.

Протестировать программу для покупки 2х билетов, 4х билетов, 10 билетов.

Программу реализовать с оператора Case.

Написать блок-схему программы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lerapro123
07.03.2020 13:22
Program Sum;
Var a, b: Integer;
Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
WriteLn('Сумма a и b равна ', a + b);
ReadLn;
End.

Program SumRow;
Const min = 5; max = 28;
Var a, i: Integer;
Begin
a := 0;
For i := min To max Do
a := a + i;
WriteLn('Сумма ряда равна ', a);
ReadLn;
End.

Program Digit;
Var a, b: LongInt;
c, d, i: Integer;
Begin
Write('a = ');
ReadLn(a);
b := 1;
c := 0;
While a Div b <> 0 Do
Begin
c := c + 1;
b := b * 10;
End;
While a > 0 Do
Begin
d := d + (a Mod 10);
a := a Div 10;
End;
WriteLn('Количество цифр в числе равно ', c);
WriteLn('Сумма цифр числа равна ', d);
ReadLn;
End.
0,0(0 оценок)
Ответ:
Каринэль
29.04.2023 16:23

1.Открыть правой рукой хлебницу; __2.Взять булку хлеба правой рукой; __3.Положить хлеб на разделочную доску; (предположим, что доска уже лежала на столе) __4.Открыть правой рукой верхний ящик стола; __5.Найти блестящий нож, длиной 20 см, с черной ручкой; __6.Взять нож в правую руку; __7.Поднести нож к хлебу; __8.Зафиксировать хлеб левой рукой, взявшись за левый край булки; __9.Расположить нож строго над правым ребром булки хлеба; __10.Повторять следующие действия 5 раз: 10.1.Отступить влево на сантиметр; 10.2.Повторять следующие действия, пока лезвие ножа не не коснется доски: 10.2.1.Прижать нож к хлебу; 10.2.2.Совершить ножом возвратно поступательное движение вперед-назад; 10.3.Поднять нож вверх; __11.Положить нож в ящик; __12.Отпустить левой рукой хлеб.

Объяснение:

Запускаем программу и смотрим, как она работает: Ой... вместе с пятым куском и палец отрезал... чёрт! остановить программу! Я же не написал как именно нужно зафиксировать хлеб левой рукой, схватился как попало и большой палец торчал в сторону... Возвращаемся к строчке "Зафиксировать хлеб левой рукой, взявшись за левый край булки;" После нее пишем: "Поджать большой палец левой руки влево, к ладони;" Запускаем программу Ой... на строчке "Положить нож в ящик;" нож упал на пол... Проклятье! оказывается, стол стоит немного под наклоном и ящик сам закрылся... Возвращаемся к коду и перед строчкой "Положить нож в ящик;" пишем "Открыть правой рукой верхний ящик стола;" Заметили ошибку? Нет?! Как мы можем открыть ящик правой рукой, если в этой руке нож? Значит, сначала нужно положить нож на стол, потом открыть ящик, снова взять нож и т.д. И делаем мы это до тех пор, пока хлеб не будет нарезан как следует, без повреждения мебели и пальцев. Вот, примерно так происходит отладка С опытом начинаешь писать программы, которые работают с первого раза, допуская минимум ошибок, а проверка "открыт ли ящик", перед складыванием в него чего-то, входит в привычку. Когда какие-то операции совершаются постоянно, такие как нарезка хлеба, мойка посуды и т.д., то программисты их описывают в виде процедур. Процедура - набор определенных действий, спрятанный под одной командой. Таким образом, текст программы, который я приводил выше, можно поместить в процедуру под названием НарезатьХлеба(параметр), где в качестве параметра будем указывать количество кусков

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота