бабочка172004
12.03.2021 09:27

9.определите значение переменной a после выполнения фрагмента программы: a: =10; b: =3; if a > b then b: =b+12 else a: =a-7; if a > b then a: =a+12 else a: =a-7; 11.определите что будет напечатано в результате работы следующей программы. var k,i: integer; begin k : =4; for i : = 1 to 3 do k : = 2*k +i; writeln(k); end. 12.определите что будет напечатано в результате работы следующей программы. var s,i: integer; begin s : =3; for i : = 2 to 5 do s : = s+2*i writeln(s) ; end 13.определите что будет напечатано в результате работы следующей программы. var s,n: integer; begin s : =1; for n : = 3 to 8 do s : = s*2 write(s) ; end. 14.чему будет равно значение переменной а после выполнения этого цикла? i: =4; a: =12; while i< 6 do begin a: =a+i; i: =i+1 end. ase

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
katecat20171
01.10.2020 01:37

9.Определите значение переменной a после выполнения фрагмента программы:

a:=10;

b:=3;

if a > b then b:=b+12//а больше б, значит к б прибавим 12 и получим что б 21

else a:=a-7;//а это игнорим

if a > b then a:=a+12//теперь а не больше б(б21 а а 10), так что к а прибавим 12, получаем а 22

else a:=a-7;// а это игнорим

А = 22.

11.Определите что будет напечатано в результате работы следующей программы.

Var k,i: integer;

Begin

k :=4;/к равно 4

For i := 1 to 3 do//следующая строка повториться 3 раза, а и при этом будет меняться от 1 до 3

k := 2*k +i;

// При и равном 1 к станет 9

// При и равном 2 к станет 20

// При и равном 3 к станет 43

Writeln(k);// выведет 43

end.

ответ 43

12.Определите что будет напечатано в результате работы следующей программы.

Var s,i: integer;

Begin

s :=3;

For i := 2 to 5 do// и будет меняться от 2 до 5

s := s+2*i

//К с будет прибавляется 2i т.е. сперва 3;7;13;21;31

Writeln(s) ;//31

end

ответ:31

13.Определите что будет напечатано в результате работы следующей программы.

Var s,n: integer;

Begin

s :=1;

For n := 3 to 8 do//повториться 6 раз

s := s*2// каждый раз s увеличивается вдвое, т.е.это 2 в 6 степени

write(s) ;

end.

ответ:64

14.Чему будет равно значение переменной а после выполнения этого цикла?

i:=4;

a:=12;

while i<6 do begin//по сути он повторится 2 раза, а и будет принимать значение от 4 до 5

a:=a+i;//а увеличиваем на и: сперва это 16, потом 21

i:=i+1

end.

ответ:21

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота