Кама29102007
03.03.2020 02:31

2.Написать программу вычисления значения функции у. Известно, что у = x2, если -2 <= x <= 2, у = 4 в остальных случаях
3. Написать программу, которая меньшее из двух различных значений переменных вещественного типа х и у заменяет на 0, а большее на 1.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Аня3885
01.03.2022 05:42
Type
    bignum = array[1..100] of integer;

var
    a, b: bignum;
    i, j, k, n_a, n_b: integer;

procedure get_num(var m: bignum; var n: integer);
var
    i := 0;
    s: string;
begin
    write('Введите число = ');
    readln(s);
    s := trim(s);
    n := 0;
    for i := length(s) downto 1 do
        if s[i] in ['0'..'9'] then begin
            n := n + 1;
            m[n] := strtoint(s[i]);
        end;
end;

function more(a, b: bignum; n_a: integer): boolean;
var
    i: integer;
    f := false;
begin
    for i := n_a downto 1 do
    begin
        if a[i] > b[i] then f := true
        else if a[i] < b[i] then f := false;
        if a[i] <> b[i] then break;
    end;
    more := f;
end;

procedure show(m: bignum; n: integer);
var
    i: integer;
begin
    write('Вывод ');
    for i := n downto 1 do
        write(m[i]);
    writeln();
end;

begin
    get_num(a, n_a);
    get_num(b, n_b);
   
    while (n_a >= n_b) and more(a, b, n_a) do    
    begin
        if (a[n_a] > b[n_b]) then k := n_a - n_b
        else if n_a > n_b then k := n_a - n_b - 1
        else k := 0;
       
        for i := 1 to n_b do
        begin
            a[i + k] := a[i + k] - b[i];
            if a[i + k] < 0 then begin
                for j := i + k to n_a - 1 do
                begin
                    if a[j] >= 0 then break;
                    a[j] := a[j] + 10;
                    a[j + 1] := a[j + 1] - 1;
                end
            end;
        end;
        if a[n_a] = 0 then n_a := n_a - 1;
    end;
   
    show(a, n_a);
end.
0,0(0 оценок)
Ответ:
mereizunusova
04.05.2022 18:22
program Metka;
\\ Даем имя метке
 label M1;
\\ Даем имя переменной х
var x: shortint;
\\ Начало программы
begin
\\ Выводим текст с ввода числа
M1:writeln ('Введите x>100');
\\ Запрос на ввод числа
readln(x);
\\ Если введенное число <=100 то идем на М1
if x<=100 then GOTO M1
\\ Конец программы
end.

Два недочета
1) нет точки с запятой после writeln ('x>100')
2) Неверное условие - должно быть <=, т.к. при х=100 условие х>100 не должно выполняться.
3) Желательно попросить ввести х>100 - слово Введите - не лишнее
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота